Dropbox chat support is not working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 06:09 UTC
Investigating
Chat support is currently not working as expected. We’re working to fix the problem as quickly as we can. In the meantime, please visit dropbox.com/support for alternative customer support options.
Posted Nov 16, 2023 - 01:57 UTC