Dropbox may be unavailable for some users.

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted May 14, 2025 - 19:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 18:49 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 18:33 UTC

Investigating

We are currently investigating this issue.
Posted May 14, 2025 - 18:24 UTC
This incident affected: Website, Desktop Application, Mobile Application, API, Paper, Replay, and Dash.