Dropbox may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 04:48 UTC
Identified
Dropbox may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Feb 28, 2024 - 00:57 UTC
This incident affected: Website and Paper.